CVE-2017-2297 Auth bypass in Puppet Enterprise

High 7.5 Published Updated

Attackers can bypass authentication to obtain labeled RBAC access tokens in Puppet Enterprise when labeled tokens are enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2017-2297?

CVE-2017-2297 is a high-severity authentication bypass vulnerability in Puppet Puppet Enterprise, published on 1 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Puppet Enterprise versions prior to 2016.4.5 and 2017.2.1 did not correctly authenticate users before returning labeled RBAC access tokens. This issue has been fixed in Puppet Enterprise 2016.4.5 and 2017.2.1. This only affects users with labeled tokens, which is not the default for tokens.

Weakness: CWE-287

Which versions are affected by CVE-2017-2297?

It affects 1 product.

Products include Puppet Puppet Enterprise.

How do I fix CVE-2017-2297?

No fix has been published for CVE-2017-2297 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2017-2297 being exploited?

There is no known exploitation of CVE-2017-2297 in the wild and no public exploit code.

All Puppet Puppet Enterprise vulnerabilities

Sources

Also known as GHSA-86rf-m4cq-ghm6.

Is CVE-2017-2297 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free