CVE-2017-2576 Moodle Incorrect sanitation of attributes in forums
Attackers can inject malicious scripts into Moodle forums due to improper attribute sanitization, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-2576?
CVE-2017-2576 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.
Weakness: CWE-20
Which versions are affected by CVE-2017-2576?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7 | 2.7.18 |
moodle/moodle Packagist | From 2.7 | 2.7.18 |
moodle/moodle Packagist | From 3.0 | 3.0.8 |
moodle/moodle Packagist | From 3.0 | 3.0.8 |
moodle/moodle Packagist | From 3.1 | 3.1.4 |
moodle/moodle Packagist | From 3.1 | 3.1.4 |
2 more packages
moodle/moodle Packagist | From 3.2 | 3.2.1 |
moodle/moodle Packagist | From 3.2 | 3.2.1 |
Products include Moodle Moodle.
How do I fix CVE-2017-2576?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.18, 3.0.8, 3.1.4 or 3.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-2576 being exploited?
There is no known exploitation of CVE-2017-2576 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-cjrf-xg77-chpw, UBUNTU-CVE-2017-2576.