CVE-2017-2578 Moodle Cross-site Scripting in assignment submission page
Cross-site scripting in Moodle assignment submissions allows attackers to execute scripts or hijack user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-2578?
CVE-2017-2578 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Moodle 3.x, there is XSS in the assignment submission page.
Weakness: CWE-79
Which versions are affected by CVE-2017-2578?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.4 |
moodle/moodle Packagist | From 3.1 | 3.1.4 |
moodle/moodle Packagist | From 3.2 | 3.2.1 |
moodle/moodle Packagist | From 3.2 | 3.2.1 |
Products include Moodle Moodle.
How do I fix CVE-2017-2578?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.4 or 3.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-2578 being exploited?
There is no known exploitation of CVE-2017-2578 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-6r76-f8c8-fh7p, UBUNTU-CVE-2017-2578.