# CVE-2017-2585: keycloak-core vulnerable to timing attacks against JWS token verification

> Attackers can exploit non-constant time HMAC verification in Keycloak to perform timing attacks, potentially compromising token integrity and security.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-w6gv-3r3v-gwgj

## What is CVE-2017-2585?

CVE-2017-2585 is a medium-severity vulnerability in Redhat Keycloak, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Red Hat Keycloak before version 2.5.1 has an implementation of HMAC verification for JWS tokens that uses a method that runs in non-constant time, potentially leaving the application vulnerable to timing attacks.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-2585?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 2.5.1 |
| `org.keycloak:keycloak-core` | Maven | All versions | 2.5.1 |

Products: Redhat Keycloak, Redhat Single Sign On.

## How do I fix CVE-2017-2585?

Upgrade org.keycloak:keycloak-core to 2.5.1 or later.

## Is CVE-2017-2585 being exploited?

There is no known exploitation of CVE-2017-2585 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2585 and fix it if it is affected.

What it is: CVE-2017-2585 is a medium-severity vulnerability in Redhat Keycloak, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2585 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.5.1
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2585/ (Markdown: https://insights.sbomify.com/CVE-2017-2585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2585
- OSV: https://osv.dev/vulnerability/CVE-2017-2585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2585/
Summaries are generated and may contain mistakes; the official description above is the record.
