# CVE-2017-2592: oslo.middleware Information Disclosure vulnerability

> Attackers can obtain sensitive information, such as keystone tokens, from OpenStack error logs due to improper handling of tracebacks in the CatchError class.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-2592, GHSA-xcp8-hh74-f6mc, PYSEC-2018-104, RHSA-2017:0300, RHSA-2017:0435, SUSE-SU-2017:0848-1, SUSE-SU-2017:1062-1, SUSE-SU-2018:3924-1, UBUNTU-CVE-2017-2592, USN-3666-1

## What is CVE-2017-2592?

CVE-2017-2592 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 8 May 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error message. System users could exploit this flaw to obtain sensitive information from OpenStack component error logs (for example, keystone tokens).

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2017-2592?

10 open source packages ship an affected version, including oslo-middleware and oslo.middleware. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oslo-middleware` | PyPI | All versions | 3.8.1 |
| `oslo-middleware` | PyPI | All versions | 3.8.1 |
| `oslo-middleware` | PyPI | From 3.20.0 | 3.23.1 |
| `oslo-middleware` | PyPI | From 3.20.0 | 3.23.1 |
| `oslo-middleware` | PyPI | From 3.9.0 | 3.19.1, 3.8.1, 3.23.1 |
| `oslo-middleware` | PyPI | From 3.9.0 | 3.19.1 |
| `oslo-middleware` | PyPI | From 3.9.0 | 3.19.1 |
| `oslo.middleware` | PyPI | All versions | 3.8.1 |
| `oslo.middleware` | PyPI | From 3.20.0 | 3.23.1 |
| `oslo.middleware` | PyPI | From 3.9.0 | 3.19.1 |
| `python-oslo-middleware` | Red Hat:openstack:10::el7 | All versions | 0:3.19.0-1.2.el7ost |
| `python-oslo-middleware-lang` | Red Hat:openstack:10::el7 | All versions | 0:3.19.0-1.2.el7ost |
| `python-oslo-middleware-tests` | Red Hat:openstack:10::el7 | All versions | 0:3.19.0-1.2.el7ost |
| `python-oslo-middleware` | Red Hat:openstack:9::el7 | All versions | 0:3.7.0-2.el7ost |
| `python-oslo-middleware-tests` | Red Hat:openstack:9::el7 | All versions | 0:3.7.0-2.el7ost |
| `python-oslo.middleware` | SUSE:OpenStack Cloud 6 | All versions | 2.8.0-3.1 |
| `python-oslo.cache` | SUSE:OpenStack Cloud 7 | All versions | 1.14.1-3.3.3 |
| `python-oslo.concurrency` | SUSE:OpenStack Cloud 7 | All versions | 3.14.1-3.3.3 |
| `python-oslo.db` | SUSE:OpenStack Cloud 7 | All versions | 4.13.6-3.3.3 |
| `python-oslo.log` | SUSE:OpenStack Cloud 7 | All versions | 3.16.1-3.3.3 |
| `python-oslo.messaging` | SUSE:OpenStack Cloud 7 | All versions | 5.10.2-3.6.3 |
| `python-oslo.middleware` | SUSE:OpenStack Cloud 7 | All versions | 3.19.0-3.1 |
| `python-oslo.middleware` | SUSE:OpenStack Cloud 7 | All versions | 3.19.1-4.3.4 |
| `python-oslo.serialization` | SUSE:OpenStack Cloud 7 | All versions | 2.13.2-3.3.3 |
| `python-oslo.service` | SUSE:OpenStack Cloud 7 | All versions | 1.16.1-3.3.1 |
| `python-oslo.utils` | SUSE:OpenStack Cloud 7 | All versions | 3.16.1-3.3.3 |
| `python-oslo.versionedobjects` | SUSE:OpenStack Cloud 7 | All versions | 1.17.1-3.3.1 |
| `python-oslo.vmware` | SUSE:OpenStack Cloud 7 | All versions | 2.14.1-3.3.1 |
| `python-oslotest` | SUSE:OpenStack Cloud 7 | All versions | 2.10.1-3.3.1 |

Products: Canonical Ubuntu Linux, Openstack Oslo.middleware.

## How do I fix CVE-2017-2592?

Upgrade oslo-middleware to a fixed version for your release line: 3.8.1, 3.23.1 or 3.19.1.

## Is CVE-2017-2592 being exploited?

There is no known exploitation of CVE-2017-2592 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2592 and fix it if it is affected.

What it is: CVE-2017-2592 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 8 May 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-2592 in the wild and no public exploit code.

Affected packages and fixed versions:
- oslo-middleware (PyPI): affected all versions; fixed in 3.8.1
- oslo-middleware (PyPI): affected all versions; fixed in 3.8.1
- oslo-middleware (PyPI): affected from 3.20.0; fixed in 3.23.1
- oslo-middleware (PyPI): affected from 3.20.0; fixed in 3.23.1
- oslo-middleware (PyPI): affected from 3.9.0; fixed in 3.19.1, 3.8.1, 3.23.1
- oslo-middleware (PyPI): affected from 3.9.0; fixed in 3.19.1
- oslo-middleware (PyPI): affected from 3.9.0; fixed in 3.19.1
- oslo.middleware (PyPI): affected all versions; fixed in 3.8.1
- oslo.middleware (PyPI): affected from 3.20.0; fixed in 3.23.1
- oslo.middleware (PyPI): affected from 3.9.0; fixed in 3.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2592/ (Markdown: https://insights.sbomify.com/CVE-2017-2592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2592
- OSV: https://osv.dev/vulnerability/CVE-2017-2592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2592/
Summaries are generated and may contain mistakes; the official description above is the record.
