CVE-2017-2599 Incorrect Authorization in Jenkins

Medium 5.4 Published Updated

Users with item creation permissions can overwrite existing items they lack access to, compromising data integrity in Jenkins.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-2599?

CVE-2017-2599 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 11 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before versions 2.44 and 2.32.2 is vulnerable to an insufficient permission check. This allows users with permissions to create new items (e.g. jobs) to overwrite existing items they don't have access to (SECURITY-321).

Weakness: CWE-863

Which versions are affected by CVE-2017-2599?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2599?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2017-2599 being exploited?

There is no known exploitation of CVE-2017-2599 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-7r4h-2h23-6jq9.

Is CVE-2017-2599 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free