CVE-2017-2600 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

Medium 4.3 Published Updated

Low-privilege users can view sensitive node monitor data, including system configuration and runtime information, via the remote API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-2600?

CVE-2017-2600 is a medium-severity vulnerability in Jenkins Jenkins, published on 15 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In jenkins before versions 2.44, 2.32.2 node monitor data could be viewed by low privilege users via the remote API. These included system configuration and runtime information of these nodes (SECURITY-343).

Weakness: CWE-200, CWE-325

Which versions are affected by CVE-2017-2600?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2600?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Is CVE-2017-2600 being exploited?

There is no known exploitation of CVE-2017-2600 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-wj5c-j656-h5fw.

Is CVE-2017-2600 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free