CVE-2017-2601 Cross-site Scripting in Jenkins

Medium 6.1 Published Updated

Attackers with job configuration permissions can inject JavaScript into parameter names and descriptions, leading to persistent cross-site scripting attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-2601?

CVE-2017-2601 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 10 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.

Weakness: CWE-79

Which versions are affected by CVE-2017-2601?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2601?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-2601 being exploited?

There is no known exploitation of CVE-2017-2601 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-r69c-5j7c-vm6q.

Is CVE-2017-2601 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free