CVE-2017-2602 Incomplete List of Disallowed Inputs in Jenkins

Low 3.1 Published Updated

Malicious agents can write to protected metadata files due to improper blacklisting, allowing unauthorized data modification in Jenkins.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-2602?

CVE-2017-2602 is a low-severity missing authorization vulnerability in Jenkins Jenkins, published on 15 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

jenkins before versions 2.44, 2.32.2 is vulnerable to an improper blacklisting of the Pipeline metadata files in the agent-to-master security subsystem. This could allow metadata files to be written to by malicious agents (SECURITY-358).

Weakness: CWE-184

Which versions are affected by CVE-2017-2602?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2602?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2017-2602 being exploited?

There is no known exploitation of CVE-2017-2602 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-ffgg-vphh-v273.

Is CVE-2017-2602 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free