CVE-2017-2603 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

Low 2.6 Published Updated

Attackers can leak sensitive data like API tokens from disconnected agents via the config.xml API in Jenkins.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-2603?

CVE-2017-2603 is a low-severity vulnerability in Jenkins Jenkins, published on 15 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Jenkins before versions 2.44, 2.32.2 is vulnerable to a user data leak in disconnected agents' config.xml API. This could leak sensitive data such as API tokens (SECURITY-362).

Weakness: CWE-200, CWE-325

Which versions are affected by CVE-2017-2603?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2603?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Is CVE-2017-2603 being exploited?

There is no known exploitation of CVE-2017-2603 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-x55p-6526-xmmp.

Is CVE-2017-2603 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free