CVE-2017-2604 Improper Authentication in Jenkins

Medium 4.3 Published Updated

Low-privilege users can bypass permission checks to act on administrative monitors in Jenkins, potentially escalating privileges.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-2604?

CVE-2017-2604 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 15 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Jenkins before versions 2.44, 2.32.2 low privilege users were able to act on administrative monitors due to them not being consistently protected by permission checks (SECURITY-371).

Weakness: CWE-287, CWE-358

Which versions are affected by CVE-2017-2604?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2604?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2017-2604 being exploited?

There is no known exploitation of CVE-2017-2604 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-m93h-5qmx-pphg.

Is CVE-2017-2604 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free