CVE-2017-2608 Deserialization of Untrusted Data in Jenkins

High 8.8 Published Updated

Attackers can execute arbitrary code on Jenkins servers by exploiting unsafe deserialization in XStream-based APIs.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-2608?

CVE-2017-2608 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 15 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before versions 2.44, 2.32.2 is vulnerable to a remote code execution vulnerability involving the deserialization of various types in javax.imageio in XStream-based APIs (SECURITY-383).

Weakness: CWE-502

Which versions are affected by CVE-2017-2608?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2608?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2017-2608 being exploited?

There is no known exploitation of CVE-2017-2608 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-fwqr-3pvp-pjwq.

Is CVE-2017-2608 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free