CVE-2017-2609 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

Medium 4.3 Published Updated

Attackers can view names of restricted Jenkins views via search autocomplete, exposing sensitive project structure information.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-2609?

CVE-2017-2609 is a medium-severity vulnerability in Jenkins Jenkins, published on 22 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

jenkins before versions 2.44, 2.32.2 is vulnerable to an information disclosure vulnerability in search suggestions (SECURITY-385). The autocomplete feature on the search box discloses the names of the views in its suggestions, including the ones for which the current user does not have access to.

Weakness: CWE-200

Which versions are affected by CVE-2017-2609?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2609?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Is CVE-2017-2609 being exploited?

There is no known exploitation of CVE-2017-2609 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-v222-w2mw-xjc6.

Is CVE-2017-2609 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free