# CVE-2017-2609: Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

> Attackers can view names of restricted Jenkins views via search autocomplete, exposing sensitive project structure information.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-v222-w2mw-xjc6

## What is CVE-2017-2609?

CVE-2017-2609 is a medium-severity vulnerability in Jenkins Jenkins, published on 22 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

jenkins before versions 2.44, 2.32.2 is vulnerable to an information disclosure vulnerability in search suggestions (SECURITY-385). The autocomplete feature on the search box discloses the names of the views in its suggestions, including the ones for which the current user does not have access to.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-2609?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.32.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.32.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.34 | 2.44 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.34 | 2.44 |

Products: Jenkins Jenkins.

## How do I fix CVE-2017-2609?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

## Is CVE-2017-2609 being exploited?

There is no known exploitation of CVE-2017-2609 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2609 and fix it if it is affected.

What it is: CVE-2017-2609 is a medium-severity vulnerability in Jenkins Jenkins, published on 22 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2609 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.32.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.32.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.34; fixed in 2.44
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.34; fixed in 2.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2609/ (Markdown: https://insights.sbomify.com/CVE-2017-2609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2609
- OSV: https://osv.dev/vulnerability/CVE-2017-2609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2609/
Summaries are generated and may contain mistakes; the official description above is the record.
