CVE-2017-2610 Improper Neutralization of Input During Web Page Generation in Jenkins

Medium 5.4 Published Updated

Attackers can inject malicious scripts via user names in search suggestions, potentially leading to session hijacking or code execution on Jenkins servers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-2610?

CVE-2017-2610 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 15 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in search suggestions due to improperly escaping users with less-than and greater-than characters in their names (SECURITY-388).

Weakness: CWE-79

Which versions are affected by CVE-2017-2610?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2610?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-2610 being exploited?

There is no known exploitation of CVE-2017-2610 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-jff5-55xj-4jcq.

Is CVE-2017-2610 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free