# CVE-2017-2611: Incorrect Authorization in Jenkins Core

> Users with read access can trigger background cleanup processes, potentially causing excessive load and denial of service on Jenkins.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3297-944x-j7x7

## What is CVE-2017-2611?

CVE-2017-2611 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 8 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins before versions 2.44, 2.32.2 is vulnerable to an insufficient permission check for periodic processes (SECURITY-389). The URLs /workspaceCleanup and /fingerprintCleanup did not perform permission checks, allowing users with read access to Jenkins to trigger these background processes (that are otherwise performed daily), possibly causing additional load on Jenkins master and agents.

Weakness: CWE-863 (Incorrect Authorization), CWE-358 (Improperly Implemented Security Check for Standard)

## Which versions are affected by CVE-2017-2611?

2 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.44 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.44 |

Products: Jenkins Jenkins, Redhat Openshift.

## How do I fix CVE-2017-2611?

Upgrade org.jenkins-ci.main:jenkins-core to 2.44 or later.

## Is CVE-2017-2611 being exploited?

There is no known exploitation of CVE-2017-2611 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2611 and fix it if it is affected.

What it is: CVE-2017-2611 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 8 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2611 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.44
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2611/ (Markdown: https://insights.sbomify.com/CVE-2017-2611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2611
- OSV: https://osv.dev/vulnerability/CVE-2017-2611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2611/
Summaries are generated and may contain mistakes; the official description above is the record.
