CVE-2017-2612 Incorrect Permission Assignment for Critical Resource in Jenkins
Low-privilege users can override JDK download credentials, potentially causing build failures and escalating privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-2612?
CVE-2017-2612 is a medium-severity vulnerability in Jenkins Jenkins, published on 15 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Jenkins before versions 2.44, 2.32.2 low privilege users were able to override JDK download credentials (SECURITY-392), resulting in future builds possibly failing to download a JDK.
Which versions are affected by CVE-2017-2612?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.32.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.32.2 |
org.jenkins-ci.main:jenkins-core Maven | From 2.34 | 2.44 |
org.jenkins-ci.main:jenkins-core Maven | From 2.34 | 2.44 |
Products include Jenkins Jenkins.
How do I fix CVE-2017-2612?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.
Is CVE-2017-2612 being exploited?
There is no known exploitation of CVE-2017-2612 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-wf9g-rh76-6jvr.