CVE-2017-2613 Cross-Site Request Forgery in Jenkins

Medium 5.4 Published Updated

Attackers can trick administrators into creating excessive user records via CSRF, potentially causing resource exhaustion or denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-2613?

CVE-2017-2613 is a medium-severity vulnerability in Jenkins Jenkins, published on 15 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

jenkins before versions 2.44, 2.32.2 is vulnerable to a user creation CSRF using GET by admins. While this user record was only retained until restart in most cases, administrators' web browsers could be manipulated to create a large number of user records (SECURITY-406).

Weakness: CWE-352, CWE-770

Which versions are affected by CVE-2017-2613?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.32.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44
org.jenkins-ci.main:jenkins-core MavenFrom 2.342.44

Products include Jenkins Jenkins.

How do I fix CVE-2017-2613?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.

Is CVE-2017-2613 being exploited?

There is no known exploitation of CVE-2017-2613 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-pwv6-872c-gcg6.

Is CVE-2017-2613 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free