{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2613 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.32.2 or 2.44.","what":"CVE-2017-2613 is a medium-severity vulnerability in Jenkins Jenkins, published on 15 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-2613 and fix it if it is affected.\n\nWhat it is: CVE-2017-2613 is a medium-severity vulnerability in Jenkins Jenkins, published on 15 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-2613 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.32.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.32.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.34; fixed in 2.44\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.34; fixed in 2.44\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2613/ (Markdown: https://insights.sbomify.com/CVE-2017-2613/index.md)","id":"CVE-2017-2613","markdown":"https://insights.sbomify.com/CVE-2017-2613/index.md","name":"CVE-2017-2613","record":{"aliases":["GHSA-pwv6-872c-gcg6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins automation server","requires_auth":"none","summary":"Attackers can trick administrators into creating excessive user records via CSRF, potentially causing resource exhaustion or denial of service.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jenkins","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"jenkins before versions 2.44, 2.32.2 is vulnerable to a user creation CSRF using GET by admins. While this user record was only retained until restart in most cases, administrators' web browsers could be manipulated to create a large number of user records (SECURITY-406).","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery in Jenkins","id":"CVE-2017-2613","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"jenkins:jenkins","products":["jenkins:jenkins"],"type":"csrf","year":"2017"},"n_packages":4,"n_references":4,"next":{"headline":"Auth bypass in ovirt-engine-extension-aaa-jdbc","id":"CVE-2017-2614"},"packages":[{"ecosystem":"Maven","fixed":["2.32.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-pwv6-872c-gcg6"},{"ecosystem":"Maven","fixed":["2.32.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-pwv6-872c-gcg6"},{"ecosystem":"Maven","fixed":["2.44"],"introduced":["2.34"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-pwv6-872c-gcg6"},{"ecosystem":"Maven","fixed":["2.44"],"introduced":["2.34"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-pwv6-872c-gcg6"}],"prev":{"headline":"Incorrect Permission Assignment for Critical Resource in Jenkins","id":"CVE-2017-2612"},"products":["jenkins"],"published":"2018-05-15","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"Attackers can trick administrators into creating excessive user records via CSRF, potentially causing resource exhaustion or denial of service.","url":"https://insights.sbomify.com/CVE-2017-2613/"}