# CVE-2017-2638: Infinispan Rest API Does Not Enforce Auth Constraints

> Attackers can read or modify cache data via the REST API due to missing authentication constraints in Infinispan.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mvxp-3j62-jqr6

## What is CVE-2017-2638?

CVE-2017-2638 is a medium-severity missing authorization vulnerability in [UNKNOWN] infinispan, published on 16 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It was found that the REST API in Infinispan before version 9.0.0 did not properly enforce auth constraints. An attacker could use this vulnerability to read or modify data in the default cache or a known cache name.

Weakness: CWE-287 (Improper Authentication), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2017-2638?

2 open source packages ship an affected version, including org.infinispan:infinispan-server-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.infinispan:infinispan-server-core` | Maven | All versions | 9.0.0 |
| `org.infinispan:infinispan-server-core` | Maven | All versions | 9.0.0 |

Products: Infinispan Infinispan, Redhat Jboss Data Grid.

## How do I fix CVE-2017-2638?

Upgrade org.infinispan:infinispan-server-core to 9.0.0 or later.

## Is CVE-2017-2638 being exploited?

There is no known exploitation of CVE-2017-2638 in the wild and no public exploit code.

## Other vulnerabilities in [UNKNOWN] infinispan

- [CVE-2018-1131](https://insights.sbomify.com/CVE-2018-1131/): Deserialization of Untrusted Data in Infinispan (high 8.8)
- [CVE-2017-15089](https://insights.sbomify.com/CVE-2017-15089/): Deserialization of Untrusted Data in Infinispan (high 8.8)
- [CVE-2019-10174](https://insights.sbomify.com/CVE-2019-10174/): Use of Externally-Controlled Input to Select Classes or Code in Infinispan (high 7.5)
- [CVE-2023-5384](https://insights.sbomify.com/CVE-2023-5384/): Infinispan: credentials returned from configuration as clear text (high 7.2)
- [CVE-2023-3628](https://insights.sbomify.com/CVE-2023-3628/): Infispan: rest bulk ops don't check permissions (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2638 and fix it if it is affected.

What it is: CVE-2017-2638 is a medium-severity missing authorization vulnerability in [UNKNOWN] infinispan, published on 16 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2638 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.infinispan:infinispan-server-core (Maven): affected all versions; fixed in 9.0.0
- org.infinispan:infinispan-server-core (Maven): affected all versions; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2638/ (Markdown: https://insights.sbomify.com/CVE-2017-2638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2638
- OSV: https://osv.dev/vulnerability/CVE-2017-2638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2638/
Summaries are generated and may contain mistakes; the official description above is the record.
