{"answers":{"affected":"It affects 7 products.","exploited":"There is no known exploitation of CVE-2017-2640 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-2640 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-2640 and fix it if it is affected.\n\nWhat it is: CVE-2017-2640 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-2640 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2640/ (Markdown: https://insights.sbomify.com/CVE-2017-2640/index.md)","id":"CVE-2017-2640","markdown":"https://insights.sbomify.com/CVE-2017-2640/index.md","name":"CVE-2017-2640","record":{"aliases":["ALPINE-CVE-2017-2640","DEBIAN-CVE-2017-2640","DLA-853-1","DSA-3806-1","GHSA-556c-qpr9-626c","MGASA-2017-0102","SUSE-SU-2018:2235-1","UBUNTU-CVE-2017-2640","USN-3231-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Pidgin instant messenger","requires_auth":"none","summary":"A malicious server can trigger an out-of-bounds write in Pidgin, leading to arbitrary code execution or application crashes.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"pidgin","vendor":"pidgin"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_server_aus","vendor":"redhat"},{"product":"enterprise_linux_server_eus","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"An out-of-bounds write flaw was found in the way Pidgin before 2.12.0 processed XML content. A malicious remote server could potentially use this flaw to crash Pidgin or execute arbitrary code in the context of the pidgin process.","ecosystems":["SUSE:Linux Enterprise Software Development Kit 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in pidgin","id":"CVE-2017-2640","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","pidgin:pidgin","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_server_aus","redhat:enterprise_linux_server_eus","redhat:enterprise_linux_workstation"],"type":"memory_corruption","year":"2017"},"n_packages":1,"n_references":5,"next":{"headline":"Moodle SQL injection via user preferences","id":"CVE-2017-2641"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["2.6.6-0.30.3.1"],"introduced":["0"],"last_affected":[],"package":"pidgin","purl":"pkg:rpm/suse/pidgin\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2018:2235-1"}],"prev":{"headline":"Security feature bypass in CloudForms","id":"CVE-2017-2639"},"products":["pidgin"],"published":"2018-07-27","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Pidgin"]},"summary":"A malicious server can trigger an out-of-bounds write in Pidgin, leading to arbitrary code execution or application crashes.","url":"https://insights.sbomify.com/CVE-2017-2640/"}