{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2641 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.7.19, 3.0.9, 3.1.5 or 3.2.2.","what":"CVE-2017-2641 is a critical SQL injection vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-2641 and fix it if it is affected.\n\nWhat it is: CVE-2017-2641 is a critical SQL injection vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-2641 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.19\n- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.19\n- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.9\n- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.9\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.5\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.5\n- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2\n- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2641/ (Markdown: https://insights.sbomify.com/CVE-2017-2641/index.md)","id":"CVE-2017-2641","markdown":"https://insights.sbomify.com/CVE-2017-2641/index.md","name":"CVE-2017-2641","record":{"aliases":["GHSA-xhq3-455r-xv44"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"SQL injection in Moodle allows attackers to manipulate database queries via user preferences, potentially exposing or altering sensitive data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"In Moodle 2.x and 3.x, SQL injection can occur via user preferences.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2017-04-06","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-04-06","kind":"exploitdb","ref":"41828","stars":null,"title":"Moodle 2.x/3.x - SQL Injection"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Moodle SQL injection via user preferences","id":"CVE-2017-2641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"sql_injection","year":"2017"},"n_packages":8,"n_references":4,"next":{"headline":"Moodle User fullname disclosure on user preferences page","id":"CVE-2017-2642"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.19"],"introduced":["2.7"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xhq3-455r-xv44"},{"ecosystem":"Packagist","fixed":["2.7.19"],"introduced":["2.7"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xhq3-455r-xv44"},{"ecosystem":"Packagist","fixed":["3.0.9"],"introduced":["3.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xhq3-455r-xv44"},{"ecosystem":"Packagist","fixed":["3.0.9"],"introduced":["3.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xhq3-455r-xv44"},{"ecosystem":"Packagist","fixed":["3.1.5"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xhq3-455r-xv44"},{"ecosystem":"Packagist","fixed":["3.1.5"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xhq3-455r-xv44"},{"ecosystem":"Packagist","fixed":["3.2.2"],"introduced":["3.2"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xhq3-455r-xv44"},{"ecosystem":"Packagist","fixed":["3.2.2"],"introduced":["3.2"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xhq3-455r-xv44"}],"prev":{"headline":"Memory corruption in pidgin","id":"CVE-2017-2640"},"products":["Moodle 2.x and 3.x"],"published":"2017-03-26","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"SQL injection in Moodle allows attackers to manipulate database queries via user preferences, potentially exposing or altering sensitive data.","url":"https://insights.sbomify.com/CVE-2017-2641/"}