# CVE-2017-2641: Moodle SQL injection via user preferences

> SQL injection in Moodle allows attackers to manipulate database queries via user preferences, potentially exposing or altering sensitive data.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xhq3-455r-xv44

## What is CVE-2017-2641?

CVE-2017-2641 is a critical SQL injection vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Moodle 2.x and 3.x, SQL injection can occur via user preferences.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-2641?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.7 | 2.7.19 |
| `moodle/moodle` | Packagist | From 2.7 | 2.7.19 |
| `moodle/moodle` | Packagist | From 3.0 | 3.0.9 |
| `moodle/moodle` | Packagist | From 3.0 | 3.0.9 |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.5 |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.5 |
| `moodle/moodle` | Packagist | From 3.2 | 3.2.2 |
| `moodle/moodle` | Packagist | From 3.2 | 3.2.2 |

Products: Moodle Moodle.

## How do I fix CVE-2017-2641?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.19, 3.0.9, 3.1.5 or 3.2.2.

## Is CVE-2017-2641 being exploited?

There is no known exploitation of CVE-2017-2641 in the wild and no public exploit code.

Public exploit code:

- Moodle 2.x/3.x - SQL Injection (exploitdb)

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2641 and fix it if it is affected.

What it is: CVE-2017-2641 is a critical SQL injection vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2641 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.19
- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.19
- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.9
- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.9
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.5
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.5
- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2
- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2641/ (Markdown: https://insights.sbomify.com/CVE-2017-2641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2641
- OSV: https://osv.dev/vulnerability/CVE-2017-2641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2641/
Summaries are generated and may contain mistakes; the official description above is the record.
