# CVE-2017-2643: Moodle Global search displays user names for unauthenticated users

> Unauthenticated users can view user names in Moodle's global search, exposing personal information.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-98mf-mqw9-9q8q

## What is CVE-2017-2643?

CVE-2017-2643 is a medium-severity vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Moodle 3.2.x, global search displays user names for unauthenticated users.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-2643?

2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.2 | 3.2.2 |
| `moodle/moodle` | Packagist | From 3.2 | 3.2.2 |

Products: Moodle Moodle.

## How do I fix CVE-2017-2643?

Upgrade moodle/moodle to 3.2.2 or later.

## Is CVE-2017-2643 being exploited?

There is no known exploitation of CVE-2017-2643 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2643 and fix it if it is affected.

What it is: CVE-2017-2643 is a medium-severity vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2643 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2
- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2643/ (Markdown: https://insights.sbomify.com/CVE-2017-2643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2643
- OSV: https://osv.dev/vulnerability/CVE-2017-2643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2643/
Summaries are generated and may contain mistakes; the official description above is the record.
