CVE-2017-2644 Moodle XSS Vulnerability
Cross-site scripting vulnerability in Moodle allows attackers to inject malicious scripts via evidence of prior learning features.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-2644?
CVE-2017-2644 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Moodle 3.x, XSS can occur via evidence of prior learning.
Weakness: CWE-79
Which versions are affected by CVE-2017-2644?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1.0 | 3.1.5 |
moodle/moodle Packagist | From 3.1.0 | 3.1.5 |
moodle/moodle Packagist | From 3.2.0 | 3.2.2 |
moodle/moodle Packagist | From 3.2.0 | 3.2.2 |
Products include Moodle Moodle.
How do I fix CVE-2017-2644?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.5 or 3.2.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-2644 being exploited?
There is no known exploitation of CVE-2017-2644 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-93gj-rg98-h7mm.