# CVE-2017-2644: Moodle XSS Vulnerability

> Cross-site scripting vulnerability in Moodle allows attackers to inject malicious scripts via evidence of prior learning features.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-93gj-rg98-h7mm

## What is CVE-2017-2644?

CVE-2017-2644 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Moodle 3.x, XSS can occur via evidence of prior learning.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-2644?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.1.0 | 3.1.5 |
| `moodle/moodle` | Packagist | From 3.1.0 | 3.1.5 |
| `moodle/moodle` | Packagist | From 3.2.0 | 3.2.2 |
| `moodle/moodle` | Packagist | From 3.2.0 | 3.2.2 |

Products: Moodle Moodle.

## How do I fix CVE-2017-2644?

Upgrade moodle/moodle to a fixed version for your release line: 3.1.5 or 3.2.2.

## Is CVE-2017-2644 being exploited?

There is no known exploitation of CVE-2017-2644 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2644 and fix it if it is affected.

What it is: CVE-2017-2644 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-2644 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.1.0; fixed in 3.1.5
- moodle/moodle (Packagist): affected from 3.1.0; fixed in 3.1.5
- moodle/moodle (Packagist): affected from 3.2.0; fixed in 3.2.2
- moodle/moodle (Packagist): affected from 3.2.0; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2644/ (Markdown: https://insights.sbomify.com/CVE-2017-2644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2644
- OSV: https://osv.dev/vulnerability/CVE-2017-2644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2644/
Summaries are generated and may contain mistakes; the official description above is the record.
