{"answers":{"affected":"4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2645 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.1.5 or 3.2.2.","what":"CVE-2017-2645 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-2645 and fix it if it is affected.\n\nWhat it is: CVE-2017-2645 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 26 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-2645 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.5\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.5\n- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2\n- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2645/ (Markdown: https://insights.sbomify.com/CVE-2017-2645/index.md)","id":"CVE-2017-2645","markdown":"https://insights.sbomify.com/CVE-2017-2645/index.md","name":"CVE-2017-2645","record":{"aliases":["GHSA-9cg4-4f87-jhm3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Cross-site scripting vulnerability in Moodle allows attackers to inject malicious scripts via evidence attachments, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Moodle 3.x, XSS can occur via attachments to evidence of prior learning.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle XSS in attachments to evidence of prior learning","id":"CVE-2017-2645","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2017"},"n_packages":4,"n_references":3,"next":{"headline":"Keycloak vulnerable to infinite loop based Denial of Service","id":"CVE-2017-2646"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.5"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-9cg4-4f87-jhm3"},{"ecosystem":"Packagist","fixed":["3.1.5"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-9cg4-4f87-jhm3"},{"ecosystem":"Packagist","fixed":["3.2.2"],"introduced":["3.2"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-9cg4-4f87-jhm3"},{"ecosystem":"Packagist","fixed":["3.2.2"],"introduced":["3.2"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-9cg4-4f87-jhm3"}],"prev":{"headline":"Moodle XSS Vulnerability","id":"CVE-2017-2644"},"products":["Moodle 3.x"],"published":"2017-03-26","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in Moodle allows attackers to inject malicious scripts via evidence attachments, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2017-2645/"}