{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:ssh-slaves. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2648 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:ssh-slaves to 1.15 or later.","what":"CVE-2017-2648 is a medium-severity vulnerability in jenkins-ssh-slaves-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-2648 and fix it if it is affected.\n\nWhat it is: CVE-2017-2648 is a medium-severity vulnerability in jenkins-ssh-slaves-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-2648 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:ssh-slaves (Maven): affected all versions; fixed in 1.15\n- org.jenkins-ci.plugins:ssh-slaves (Maven): affected all versions; fixed in 1.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2648/ (Markdown: https://insights.sbomify.com/CVE-2017-2648/index.md)","id":"CVE-2017-2648","markdown":"https://insights.sbomify.com/CVE-2017-2648/index.md","name":"CVE-2017-2648","record":{"aliases":["GHSA-x654-4wjh-74q6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins SSH plugin","requires_auth":"none","summary":"Jenkins SSH slaves plugin fails to verify host keys, allowing Man-in-the-Middle attacks to intercept or modify SSH connections.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ssh_slaves","vendor":"jenkins"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"It was found that jenkins-ssh-slaves-plugin before version 1.15 did not perform host key verification, thereby enabling Man-in-the-Middle attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins SSH Build Agents Plugin did not verify host keys","id":"CVE-2017-2648","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Jenkins Active Directory Plugin did not verify certificate of AD server","id":"CVE-2017-2649"},"packages":[{"ecosystem":"Maven","fixed":["1.15"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ssh-slaves","purl":null,"source":"GHSA-x654-4wjh-74q6"},{"ecosystem":"Maven","fixed":["1.15"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ssh-slaves","purl":"pkg:maven/org.jenkins-ci.plugins/ssh-slaves","source":"GHSA-x654-4wjh-74q6"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2017-2647"},"products":["jenkins-ssh-slaves-plugin"],"published":"2018-07-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins"]},"summary":"Jenkins SSH slaves plugin fails to verify host keys, allowing Man-in-the-Middle attacks to intercept or modify SSH connections.","url":"https://insights.sbomify.com/CVE-2017-2648/"}