# CVE-2017-2648: Jenkins SSH Build Agents Plugin did not verify host keys

> Jenkins SSH slaves plugin fails to verify host keys, allowing Man-in-the-Middle attacks to intercept or modify SSH connections.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x654-4wjh-74q6

## What is CVE-2017-2648?

CVE-2017-2648 is a medium-severity vulnerability in jenkins-ssh-slaves-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

It was found that jenkins-ssh-slaves-plugin before version 1.15 did not perform host key verification, thereby enabling Man-in-the-Middle attacks.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2017-2648?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ssh-slaves. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ssh-slaves` | Maven | All versions | 1.15 |
| `org.jenkins-ci.plugins:ssh-slaves` | Maven | All versions | 1.15 |

Products: Jenkins Ssh Slaves.

## How do I fix CVE-2017-2648?

Upgrade org.jenkins-ci.plugins:ssh-slaves to 1.15 or later.

## Is CVE-2017-2648 being exploited?

There is no known exploitation of CVE-2017-2648 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2648 and fix it if it is affected.

What it is: CVE-2017-2648 is a medium-severity vulnerability in jenkins-ssh-slaves-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-2648 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ssh-slaves (Maven): affected all versions; fixed in 1.15
- org.jenkins-ci.plugins:ssh-slaves (Maven): affected all versions; fixed in 1.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2648/ (Markdown: https://insights.sbomify.com/CVE-2017-2648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2648
- OSV: https://osv.dev/vulnerability/CVE-2017-2648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2648/
Summaries are generated and may contain mistakes; the official description above is the record.
