{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:mailer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2651 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:mailer to 1.20 or later.","what":"CVE-2017-2651 is a low-severity vulnerability in jenkins-mailer-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-2651 and fix it if it is affected.\n\nWhat it is: CVE-2017-2651 is a low-severity vulnerability in jenkins-mailer-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-2651 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.20\n- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2651/ (Markdown: https://insights.sbomify.com/CVE-2017-2651/index.md)","id":"CVE-2017-2651","markdown":"https://insights.sbomify.com/CVE-2017-2651/index.md","name":"CVE-2017-2651","record":{"aliases":["GHSA-9v72-p5p3-9w65"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins mailer plugin","requires_auth":"none","summary":"An attacker can cause emails to be sent to unauthorized individuals due to flawed user mapping in the Jenkins mailer plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"mailer","vendor":"jenkins"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"jenkins-mailer-plugin before version 1.20 is vulnerable to an information disclosure while using the feature to send emails to a dynamically created list of users based on the changelogs. This could in some cases result in emails being sent to people who have no user account in Jenkins, and in rare cases even people who were not involved in whatever project was being built, due to some mapping based on the local-part of email addresses.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Jenkins-mailer-plugin","id":"CVE-2017-2651","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Missing permission checks in Jenkins Distributed Fork Plugin","id":"CVE-2017-2652"},"packages":[{"ecosystem":"Maven","fixed":["1.20"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:mailer","purl":null,"source":"GHSA-9v72-p5p3-9w65"},{"ecosystem":"Maven","fixed":["1.20"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:mailer","purl":"pkg:maven/org.jenkins-ci.plugins/mailer","source":"GHSA-9v72-p5p3-9w65"}],"prev":{"headline":"Jenkins Pipeline Classpath Step plugin allowed Script Security sandbox bypass","id":"CVE-2017-2650"},"products":["jenkins-mailer-plugin"],"published":"2018-07-27","related":[{"cvss_score":8,"headline":"Cross-Site Request Forgery in Jenkins Mailer Plugin","id":"CVE-2018-8718","kev_date_added":null,"published":"2018-03-27"},{"cvss_score":4.8,"headline":"Improper Validation of Certificate with Host Mismatch in Jenkins Mailer Plugin","id":"CVE-2020-2252","kev_date_added":null,"published":"2020-09-16"},{"cvss_score":4.3,"headline":"Cross-Site Request Forgery in Jenkins Mailer Plugin","id":"CVE-2022-20613","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":4.3,"headline":"Incorrect Permission Assignment for Critical Resource in Jenkins Mailer Plugin","id":"CVE-2022-20614","kev_date_added":null,"published":"2022-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins"]},"summary":"An attacker can cause emails to be sent to unauthorized individuals due to flawed user mapping in the Jenkins mailer plugin.","url":"https://insights.sbomify.com/CVE-2017-2651/"}