# CVE-2017-2651: Exposure of Sensitive Information to an Unauthorized Actor in Jenkins-mailer-plugin

> An attacker can cause emails to be sent to unauthorized individuals due to flawed user mapping in the Jenkins mailer plugin.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9v72-p5p3-9w65

## What is CVE-2017-2651?

CVE-2017-2651 is a low-severity vulnerability in jenkins-mailer-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jenkins-mailer-plugin before version 1.20 is vulnerable to an information disclosure while using the feature to send emails to a dynamically created list of users based on the changelogs. This could in some cases result in emails being sent to people who have no user account in Jenkins, and in rare cases even people who were not involved in whatever project was being built, due to some mapping based on the local-part of email addresses.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-2651?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:mailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:mailer` | Maven | All versions | 1.20 |
| `org.jenkins-ci.plugins:mailer` | Maven | All versions | 1.20 |

Products: Jenkins Mailer.

## How do I fix CVE-2017-2651?

Upgrade org.jenkins-ci.plugins:mailer to 1.20 or later.

## Is CVE-2017-2651 being exploited?

There is no known exploitation of CVE-2017-2651 in the wild and no public exploit code.

## Other vulnerabilities in jenkins-mailer-plugin

- [CVE-2018-8718](https://insights.sbomify.com/CVE-2018-8718/): Cross-Site Request Forgery in Jenkins Mailer Plugin (high 8.0)
- [CVE-2020-2252](https://insights.sbomify.com/CVE-2020-2252/): Improper Validation of Certificate with Host Mismatch in Jenkins Mailer Plugin (medium 4.8)
- [CVE-2022-20613](https://insights.sbomify.com/CVE-2022-20613/): Cross-Site Request Forgery in Jenkins Mailer Plugin (medium 4.3)
- [CVE-2022-20614](https://insights.sbomify.com/CVE-2022-20614/): Incorrect Permission Assignment for Critical Resource in Jenkins Mailer Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2651 and fix it if it is affected.

What it is: CVE-2017-2651 is a low-severity vulnerability in jenkins-mailer-plugin, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2651 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.20
- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2651/ (Markdown: https://insights.sbomify.com/CVE-2017-2651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2651
- OSV: https://osv.dev/vulnerability/CVE-2017-2651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2651/
Summaries are generated and may contain mistakes; the official description above is the record.
