# CVE-2017-2652: Missing permission checks in Jenkins Distributed Fork Plugin

> Attackers with basic read permissions can execute arbitrary shell commands on connected nodes due to missing authorization checks in the Distributed Fork plugin.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-2cm5-f78c-h2c8

## What is CVE-2017-2652?

CVE-2017-2652 is a high-severity missing authorization vulnerability in DistFork Jenkins plugin, published on 27 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

It was found that there were no permission checks performed in the Distributed Fork plugin before and including 1.5.0 for Jenkins that provides the dist-fork CLI command beyond the basic check for Overall/Read permission, allowing anyone with that permission to run arbitrary shell commands on all connected nodes.

Weakness: CWE-287 (Improper Authentication), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2017-2652?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:distfork. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:distfork` | Maven | All versions | 1.6.0 |
| `org.jenkins-ci.plugins:distfork` | Maven | All versions | 1.6.0 |

Products: Jenkins Distributed Fork.

## How do I fix CVE-2017-2652?

Upgrade org.jenkins-ci.plugins:distfork to 1.6.0 or later.

## Is CVE-2017-2652 being exploited?

There is no known exploitation of CVE-2017-2652 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2652 and fix it if it is affected.

What it is: CVE-2017-2652 is a high-severity missing authorization vulnerability in DistFork Jenkins plugin, published on 27 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2652 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:distfork (Maven): affected all versions; fixed in 1.6.0
- org.jenkins-ci.plugins:distfork (Maven): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2652/ (Markdown: https://insights.sbomify.com/CVE-2017-2652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2652
- OSV: https://osv.dev/vulnerability/CVE-2017-2652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2652/
Summaries are generated and may contain mistakes; the official description above is the record.
