# CVE-2017-2654: Emails were sent to addresses not associated with actual users of Jenkins by Email Extension Plugin

> The Jenkins Email Extension plugin may send build notifications to unauthorized external users due to flawed email address mapping.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-c8qr-vfjf-62q3

## What is CVE-2017-2654?

CVE-2017-2654 is a low-severity vulnerability in [UNKNOWN] jenkins-email-ext, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jenkins-email-ext before version 2.57.1 is vulnerable to an Information Exposure. The Email Extension Plugins is able to send emails to a dynamically created list of users based on the changelogs, like authors of SCM changes since the last successful build. This could in some cases result in emails being sent to people who have no user account in Jenkins, and in rare cases even people who were not involved in whatever project was being built, due to some mapping based on the local-part of email addresses.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-2654?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:email-ext. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:email-ext` | Maven | All versions | 2.57.1 |
| `org.jenkins-ci.plugins:email-ext` | Maven | All versions | 2.57.1 |

Products: Jenkins Email Extension.

## How do I fix CVE-2017-2654?

Upgrade org.jenkins-ci.plugins:email-ext to 2.57.1 or later.

## Is CVE-2017-2654 being exploited?

There is no known exploitation of CVE-2017-2654 in the wild and no public exploit code.

## Other vulnerabilities in [UNKNOWN] jenkins-email-ext

- [CVE-2023-25765](https://insights.sbomify.com/CVE-2023-25765/): Sandbox escape in Jenkins Email Extension Plugin (critical 9.9)
- [CVE-2019-1003032](https://insights.sbomify.com/CVE-2019-1003032/): Script security sandbox bypass in Jenkins Email Extension Plugin (critical 9.9)
- [CVE-2026-48920](https://insights.sbomify.com/CVE-2026-48920/): Jenkins Email Extension Plugin: Attackers able to control email content may specify `file:` URLs for images to read arbitrary files from Jenkins controller filesystem (high 8.8)
- [CVE-2020-2232](https://insights.sbomify.com/CVE-2020-2232/): Jenkins Email Extension Plugin SMTP password transmitted and displayed in plain text (high 7.5)
- [CVE-2018-1000176](https://insights.sbomify.com/CVE-2018-1000176/): Jenkins Email Extension Plugin showed plain text SMTP password in configuration form field (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2654 and fix it if it is affected.

What it is: CVE-2017-2654 is a low-severity vulnerability in [UNKNOWN] jenkins-email-ext, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2654 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:email-ext (Maven): affected all versions; fixed in 2.57.1
- org.jenkins-ci.plugins:email-ext (Maven): affected all versions; fixed in 2.57.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2654/ (Markdown: https://insights.sbomify.com/CVE-2017-2654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2654
- OSV: https://osv.dev/vulnerability/CVE-2017-2654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2654/
Summaries are generated and may contain mistakes; the official description above is the record.
