{"answers":{"affected":"2 open source packages ship an affected version, including hammer_cli_foreman. It affects 3 products.","exploited":"There is no known exploitation of CVE-2017-2667 in the wild and no public exploit code.","fix":"Upgrade hammer_cli_foreman to 0.10.0 or later.","what":"CVE-2017-2667 is a high-severity vulnerability in Redhat Satellite, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-2667 and fix it if it is affected.\n\nWhat it is: CVE-2017-2667 is a high-severity vulnerability in Redhat Satellite, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-2667 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hammer_cli_foreman (RubyGems): affected all versions; fixed in 0.10.0\n- hammer_cli_foreman (RubyGems): affected all versions; fixed in 0.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2667/ (Markdown: https://insights.sbomify.com/CVE-2017-2667/index.md)","id":"CVE-2017-2667","markdown":"https://insights.sbomify.com/CVE-2017-2667/index.md","name":"CVE-2017-2667","record":{"aliases":["GHSA-77h8-xr85-3x5q"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Foreman CLI utility","requires_auth":"none","summary":"Hammer CLI fails to verify SSL certificates, allowing attackers to intercept traffic via man-in-the-middle attacks.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"satellite","vendor":"redhat"},{"product":"satellite_capsule","vendor":"redhat"},{"product":"hammer_cli","vendor":"theforeman"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"},{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"Hammer CLI, a CLI utility for Foreman, before version 0.10.0, did not explicitly set the verify_ssl flag for apipie-bindings that disable it by default. As a result the server certificates are not checked and connections are prone to man-in-the-middle attacks.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"hammer_cli_foreman Improper Certificate Validation vulnerability","id":"CVE-2017-2667","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:satellite","products":["redhat:satellite"],"type":"weak_cryptography","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"Null dereference in 389-ds-base","id":"CVE-2017-2668"},"packages":[{"ecosystem":"RubyGems","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"hammer_cli_foreman","purl":null,"source":"GHSA-77h8-xr85-3x5q"},{"ecosystem":"RubyGems","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"hammer_cli_foreman","purl":"pkg:gem/hammer_cli_foreman","source":"GHSA-77h8-xr85-3x5q"}],"prev":{"headline":"Undertow-core vulnerable to HTTP Request Smuggling","id":"CVE-2017-2666"},"products":["Hammer CLI"],"published":"2018-03-12","related":[{"cvss_score":9.8,"headline":"Puppet-foreman: an authentication bypass vulnerability exists in foreman","id":"CVE-2024-7012","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":9.8,"headline":"Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore","id":"CVE-2024-7923","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":9.1,"headline":"Foreman: excessive permissions for viewer role on preview","id":"CVE-2026-96659","kev_date_added":null,"published":"2026-10-01"},{"cvss_score":9.1,"headline":"Foreman: arbitrary code execution through templates","id":"CVE-2023-0118","kev_date_added":null,"published":"2023-09-20"},{"cvss_score":9.1,"headline":"Hardcoded credentials in n/a","id":"CVE-2008-2369","kev_date_added":null,"published":"2008-08-14"},{"cvss_score":8.8,"headline":"Foreman: foreman: arbitrary code execution via safemode sandbox bypass","id":"CVE-2026-96658","kev_date_added":null,"published":"2026-10-01"},{"cvss_score":8.8,"headline":"Foreman: foreman: privilege escalation to administrator-level access via usergroup role assignment manipulation","id":"CVE-2026-5136","kev_date_added":null,"published":"2026-07-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Foreman"]},"summary":"Hammer CLI fails to verify SSL certificates, allowing attackers to intercept traffic via man-in-the-middle attacks.","url":"https://insights.sbomify.com/CVE-2017-2667/"}