# CVE-2017-2667: hammer_cli_foreman Improper Certificate Validation vulnerability

> Hammer CLI fails to verify SSL certificates, allowing attackers to intercept traffic via man-in-the-middle attacks.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-77h8-xr85-3x5q

## What is CVE-2017-2667?

CVE-2017-2667 is a high-severity vulnerability in Redhat Satellite, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hammer CLI, a CLI utility for Foreman, before version 0.10.0, did not explicitly set the verify_ssl flag for apipie-bindings that disable it by default. As a result the server certificates are not checked and connections are prone to man-in-the-middle attacks.

Weakness: CWE-295 (Improper Certificate Validation), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2017-2667?

2 open source packages ship an affected version, including hammer_cli_foreman. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hammer_cli_foreman` | RubyGems | All versions | 0.10.0 |
| `hammer_cli_foreman` | RubyGems | All versions | 0.10.0 |

Products: Redhat Satellite, Redhat Satellite Capsule, Theforeman Hammer Cli.

## How do I fix CVE-2017-2667?

Upgrade hammer_cli_foreman to 0.10.0 or later.

## Is CVE-2017-2667 being exploited?

There is no known exploitation of CVE-2017-2667 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Satellite

- [CVE-2024-7012](https://insights.sbomify.com/CVE-2024-7012/): Puppet-foreman: an authentication bypass vulnerability exists in foreman (critical 9.8)
- [CVE-2024-7923](https://insights.sbomify.com/CVE-2024-7923/): Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore (critical 9.8)
- [CVE-2026-96659](https://insights.sbomify.com/CVE-2026-96659/): Foreman: excessive permissions for viewer role on preview (critical 9.1)
- [CVE-2023-0118](https://insights.sbomify.com/CVE-2023-0118/): Foreman: arbitrary code execution through templates (critical 9.1)
- [CVE-2008-2369](https://insights.sbomify.com/CVE-2008-2369/): Hardcoded credentials in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2667 and fix it if it is affected.

What it is: CVE-2017-2667 is a high-severity vulnerability in Redhat Satellite, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2667 in the wild and no public exploit code.

Affected packages and fixed versions:
- hammer_cli_foreman (RubyGems): affected all versions; fixed in 0.10.0
- hammer_cli_foreman (RubyGems): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2667/ (Markdown: https://insights.sbomify.com/CVE-2017-2667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2667
- OSV: https://osv.dev/vulnerability/CVE-2017-2667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2667/
Summaries are generated and may contain mistakes; the official description above is the record.
