# CVE-2017-2670: Moderate severity vulnerability that affects io.undertow:undertow-core

> An attacker can cause a denial of service in Undertow by triggering an infinite loop via non-clean TCP closes.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-2670, GHSA-3x7h-5hfr-hvjm, UBUNTU-CVE-2017-2670

## What is CVE-2017-2670?

CVE-2017-2670 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It was found in Undertow before 1.3.28 that with non-clean TCP close, the Websocket server gets into infinite loop on every IO thread, effectively causing DoS.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2017-2670?

2 open source packages ship an affected version, including io.undertow:undertow-core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.undertow:undertow-core` | Maven | All versions | 1.3.28 |
| `io.undertow:undertow-core` | Maven | All versions | 1.3.28 |

Products: Debian Debian Linux, Redhat Jboss Enterprise Application Platform, Redhat Undertow.

## How do I fix CVE-2017-2670?

Upgrade io.undertow:undertow-core to 1.3.28 or later.

## Is CVE-2017-2670 being exploited?

There is no known exploitation of CVE-2017-2670 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2670 and fix it if it is affected.

What it is: CVE-2017-2670 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2670 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.undertow:undertow-core (Maven): affected all versions; fixed in 1.3.28
- io.undertow:undertow-core (Maven): affected all versions; fixed in 1.3.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2670/ (Markdown: https://insights.sbomify.com/CVE-2017-2670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2670
- OSV: https://osv.dev/vulnerability/CVE-2017-2670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2670/
Summaries are generated and may contain mistakes; the official description above is the record.
