# CVE-2017-2673: OpenStack Identity service (keystone) Incorrect Authorization

> Authenticated federated users can gain administrative roles in OpenStack Keystone due to an authorization flaw in federation configurations.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-2673, GHSA-j36m-hv43-7w7m, PYSEC-2018-152, RHSA-2017:1461, RHSA-2017:1597, UBUNTU-CVE-2017-2673, USN-3448-1

## What is CVE-2017-2673?

CVE-2017-2673 is a medium-severity missing authorization vulnerability in Redhat Openstack, published on 19 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authorization-check flaw was discovered in federation configurations of the OpenStack Identity service (keystone). An authenticated federated user could request permissions to a project and unintentionally be granted all related roles including administrative roles.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2017-2673?

7 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | From 10.0.0 | 10.0.2 |
| `keystone` | PyPI | From 10.0.0 | 10.0.2 |
| `keystone` | PyPI | From 11.0.0 | 11.0.1 |
| `keystone` | PyPI | From 11.0.0 | 11.0.1 |
| `keystone` | PyPI | From 9.0.0 | 10.0.2, 11.0.1 |
| `keystone` | PyPI | From 9.0.0 to 9.3.0 | None |
| `keystone` | PyPI | From 9.0.0 to 9.3.0 | None |
| `openstack-keystone` | Red Hat:openstack:10::el7 | All versions | 1:10.0.1-3.el7ost |
| `python-keystone` | Red Hat:openstack:10::el7 | All versions | 1:10.0.1-3.el7ost |
| `python-keystone-tests` | Red Hat:openstack:10::el7 | All versions | 1:10.0.1-3.el7ost |
| `openstack-keystone` | Red Hat:openstack:9::el7 | All versions | 1:9.3.0-2.el7ost |
| `python-keystone` | Red Hat:openstack:9::el7 | All versions | 1:9.3.0-2.el7ost |
| `python-keystone-tests` | Red Hat:openstack:9::el7 | All versions | 1:9.3.0-2.el7ost |

Products: Redhat Openstack.

## How do I fix CVE-2017-2673?

Upgrade keystone to a fixed version for your release line: 10.0.2 or 11.0.1.

## Is CVE-2017-2673 being exploited?

There is no known exploitation of CVE-2017-2673 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2015-1842](https://insights.sbomify.com/CVE-2015-1842/): Hardcoded credentials in n/a (critical 10.0)
- [CVE-2017-2637](https://insights.sbomify.com/CVE-2017-2637/): Auth bypass in rhosp-director (critical 9.9)
- [CVE-2022-38065](https://insights.sbomify.com/CVE-2022-38065/): Privilege escalation in OpenStack (high 8.8)
- [CVE-2016-4474](https://insights.sbomify.com/CVE-2016-4474/): Hardcoded credentials in n/a (high 8.8)
- [CVE-2021-31918](https://insights.sbomify.com/CVE-2021-31918/): Information disclosure in tripleo-ansible (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2673 and fix it if it is affected.

What it is: CVE-2017-2673 is a medium-severity missing authorization vulnerability in Redhat Openstack, published on 19 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-2673 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected from 10.0.0; fixed in 10.0.2
- keystone (PyPI): affected from 10.0.0; fixed in 10.0.2
- keystone (PyPI): affected from 11.0.0; fixed in 11.0.1
- keystone (PyPI): affected from 11.0.0; fixed in 11.0.1
- keystone (PyPI): affected from 9.0.0; fixed in 10.0.2, 11.0.1
- keystone (PyPI): affected from 9.0.0 up to 9.3.0; no fix listed
- keystone (PyPI): affected from 9.0.0 up to 9.3.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2673/ (Markdown: https://insights.sbomify.com/CVE-2017-2673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2673
- OSV: https://osv.dev/vulnerability/CVE-2017-2673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2673/
Summaries are generated and may contain mistakes; the official description above is the record.
