{"answers":{"affected":"3 open source packages ship an affected version, including ansible-vault. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2809 in the wild and no public exploit code.","fix":"Upgrade ansible-vault to 1.0.5 or later.","what":"CVE-2017-2809 is a high-severity code injection vulnerability in Tomohiro Nakamura ansible-vault, published on 14 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-2809 and fix it if it is affected.\n\nWhat it is: CVE-2017-2809 is a high-severity code injection vulnerability in Tomohiro Nakamura ansible-vault, published on 14 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-2809 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible-vault (PyPI): affected all versions; fixed in 1.0.5\n- ansible-vault (PyPI): affected all versions; fixed in 1.0.5\n- ansible-vault (PyPI): affected all versions; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2809/ (Markdown: https://insights.sbomify.com/CVE-2017-2809/index.md)","id":"CVE-2017-2809","markdown":"https://insights.sbomify.com/CVE-2017-2809/index.md","name":"CVE-2017-2809","record":{"aliases":["GHSA-c2w9-48qc-qpj4","PYSEC-2017-5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible Vault library","requires_auth":"none","summary":"Attackers can execute arbitrary Python commands by crafting a malicious Ansible Vault file, requiring an upgrade to the library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"talos","cpe":[{"product":"ansible-vault","vendor":"ansible-vault_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An exploitable vulnerability exists in the yaml loading functionality of ansible-vault before 1.0.5. A specially crafted vault can execute arbitrary python commands resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in ansible","id":"CVE-2017-2809","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":3,"n_references":5,"next":{"headline":"Loaded Databook of Tablib prone to python insertion resulting in command execution","id":"CVE-2017-2810"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"ansible-vault","purl":null,"source":"GHSA-c2w9-48qc-qpj4"},{"ecosystem":"PyPI","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"ansible-vault","purl":"pkg:pypi/ansible-vault","source":"GHSA-c2w9-48qc-qpj4"},{"ecosystem":"PyPI","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"ansible-vault","purl":"pkg:pypi/ansible-vault","source":"PYSEC-2017-5"}],"prev":{"headline":"Use after free in Ledger CLI","id":"CVE-2017-2808"},"products":["ansible-vault"],"published":"2017-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Tomohiro Nakamura"]},"summary":"Attackers can execute arbitrary Python commands by crafting a malicious Ansible Vault file, requiring an upgrade to the library.","url":"https://insights.sbomify.com/CVE-2017-2809/"}