# CVE-2017-2809: Code injection in ansible

> Attackers can execute arbitrary Python commands by crafting a malicious Ansible Vault file, requiring an upgrade to the library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-c2w9-48qc-qpj4, PYSEC-2017-5

## What is CVE-2017-2809?

CVE-2017-2809 is a high-severity code injection vulnerability in Tomohiro Nakamura ansible-vault, published on 14 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An exploitable vulnerability exists in the yaml loading functionality of ansible-vault before 1.0.5. A specially crafted vault can execute arbitrary python commands resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2017-2809?

3 open source packages ship an affected version, including ansible-vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible-vault` | PyPI | All versions | 1.0.5 |
| `ansible-vault` | PyPI | All versions | 1.0.5 |
| `ansible-vault` | PyPI | All versions | 1.0.5 |

Products: Ansible-Vault Project Ansible-Vault.

## How do I fix CVE-2017-2809?

Upgrade ansible-vault to 1.0.5 or later.

## Is CVE-2017-2809 being exploited?

There is no known exploitation of CVE-2017-2809 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2809 and fix it if it is affected.

What it is: CVE-2017-2809 is a high-severity code injection vulnerability in Tomohiro Nakamura ansible-vault, published on 14 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-2809 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible-vault (PyPI): affected all versions; fixed in 1.0.5
- ansible-vault (PyPI): affected all versions; fixed in 1.0.5
- ansible-vault (PyPI): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2809/ (Markdown: https://insights.sbomify.com/CVE-2017-2809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2809
- OSV: https://osv.dev/vulnerability/CVE-2017-2809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2809/
Summaries are generated and may contain mistakes; the official description above is the record.
