{"answers":{"affected":"3 open source packages ship an affected version, including tablib. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-2810 in the wild and no public exploit code.","fix":"Upgrade tablib to 0.11.5 or later.","what":"CVE-2017-2810 is a high-severity code injection vulnerability in Kenneth Reitz Tablib, published on 14 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-2810 and fix it if it is affected.\n\nWhat it is: CVE-2017-2810 is a high-severity code injection vulnerability in Kenneth Reitz Tablib, published on 14 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-2810 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tablib (PyPI): affected all versions; fixed in 0.11.5\n- tablib (PyPI): affected all versions; fixed in 0.11.5\n- tablib (PyPI): affected all versions; fixed in 0.11.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-2810/ (Markdown: https://insights.sbomify.com/CVE-2017-2810/index.md)","id":"CVE-2017-2810","markdown":"https://insights.sbomify.com/CVE-2017-2810/index.md","name":"CVE-2017-2810","record":{"aliases":["DEBIAN-CVE-2017-2810","GHSA-gcr6-rf47-jrgf","PYSEC-2017-95","SUSE-SU-2017:2105-1","UBUNTU-CVE-2017-2810"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python data library","requires_auth":"none","summary":"Attackers can execute arbitrary Python commands by inserting malicious code into YAML files loaded by the Tablib library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"talos","cpe":[{"product":"tablib","vendor":"python"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.","ecosystems":["PyPI","SUSE:Linux Enterprise Module for Public Cloud 12","SUSE:OpenStack Cloud 6","SUSE:OpenStack Cloud 7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Loaded Databook of Tablib prone to python insertion resulting in command execution","id":"CVE-2017-2810","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":6,"n_references":3,"next":{"headline":"Memory corruption in Kakadu SDK","id":"CVE-2017-2811"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.5"],"introduced":["0"],"last_affected":[],"package":"tablib","purl":null,"source":"GHSA-gcr6-rf47-jrgf"},{"ecosystem":"PyPI","fixed":["0.11.5"],"introduced":["0"],"last_affected":[],"package":"tablib","purl":"pkg:pypi/tablib","source":"GHSA-gcr6-rf47-jrgf"},{"ecosystem":"PyPI","fixed":["0.11.5"],"introduced":["0"],"last_affected":[],"package":"tablib","purl":"pkg:pypi/tablib","source":"PYSEC-2017-95"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 12","fixed":["0.9.11-3.1"],"introduced":["0"],"last_affected":[],"package":"python-tablib","purl":"pkg:rpm/suse/python-tablib\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2012","source":"SUSE-SU-2017:2105-1"},{"ecosystem":"SUSE:OpenStack Cloud 6","fixed":["0.9.11-3.1"],"introduced":["0"],"last_affected":[],"package":"python-tablib","purl":"pkg:rpm/suse/python-tablib\u0026distro=SUSE%20OpenStack%20Cloud%206","source":"SUSE-SU-2017:2105-1"},{"ecosystem":"SUSE:OpenStack Cloud 7","fixed":["0.9.11-3.1"],"introduced":["0"],"last_affected":[],"package":"python-tablib","purl":"pkg:rpm/suse/python-tablib\u0026distro=SUSE%20OpenStack%20Cloud%207","source":"SUSE-SU-2017:2105-1"}],"prev":{"headline":"Code injection in ansible","id":"CVE-2017-2809"},"products":["Tablib"],"published":"2017-06-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Kenneth Reitz"]},"summary":"Attackers can execute arbitrary Python commands by inserting malicious code into YAML files loaded by the Tablib library.","url":"https://insights.sbomify.com/CVE-2017-2810/"}