# CVE-2017-2810: Loaded Databook of Tablib prone to python insertion resulting in command execution

> Attackers can execute arbitrary Python commands by inserting malicious code into YAML files loaded by the Tablib library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-2810, GHSA-gcr6-rf47-jrgf, PYSEC-2017-95, SUSE-SU-2017:2105-1, UBUNTU-CVE-2017-2810

## What is CVE-2017-2810?

CVE-2017-2810 is a high-severity code injection vulnerability in Kenneth Reitz Tablib, published on 14 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.

## Which versions are affected by CVE-2017-2810?

3 open source packages ship an affected version, including tablib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tablib` | PyPI | All versions | 0.11.5 |
| `tablib` | PyPI | All versions | 0.11.5 |
| `tablib` | PyPI | All versions | 0.11.5 |
| `python-tablib` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 0.9.11-3.1 |
| `python-tablib` | SUSE:OpenStack Cloud 6 | All versions | 0.9.11-3.1 |
| `python-tablib` | SUSE:OpenStack Cloud 7 | All versions | 0.9.11-3.1 |

Products: Python Tablib.

## How do I fix CVE-2017-2810?

Upgrade tablib to 0.11.5 or later.

## Is CVE-2017-2810 being exploited?

There is no known exploitation of CVE-2017-2810 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-2810 and fix it if it is affected.

What it is: CVE-2017-2810 is a high-severity code injection vulnerability in Kenneth Reitz Tablib, published on 14 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-2810 in the wild and no public exploit code.

Affected packages and fixed versions:
- tablib (PyPI): affected all versions; fixed in 0.11.5
- tablib (PyPI): affected all versions; fixed in 0.11.5
- tablib (PyPI): affected all versions; fixed in 0.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-2810/ (Markdown: https://insights.sbomify.com/CVE-2017-2810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-2810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-2810
- OSV: https://osv.dev/vulnerability/CVE-2017-2810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-2810/
Summaries are generated and may contain mistakes; the official description above is the record.
