{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.guacamole:guacamole-common. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-3158 in the wild and no public exploit code.","fix":"Upgrade org.apache.guacamole:guacamole-common to 0.9.11-incubating or later.","what":"CVE-2017-3158 is a high-severity vulnerability in Apache Guacamole, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-3158 and fix it if it is affected.\n\nWhat it is: CVE-2017-3158 is a high-severity vulnerability in Apache Guacamole, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-3158 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.guacamole:guacamole-common (Maven): affected from 0.9.5; fixed in 0.9.11-incubating\n- org.apache.guacamole:guacamole-common (Maven): affected from 0.9.5; fixed in 0.9.11-incubating\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-3158/ (Markdown: https://insights.sbomify.com/CVE-2017-3158/index.md)","id":"CVE-2017-3158","markdown":"https://insights.sbomify.com/CVE-2017-3158/index.md","name":"CVE-2017-3158","record":{"aliases":["GHSA-3vv3-585q-wv6x","UBUNTU-CVE-2017-3158"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Guacamole","requires_auth":"none","summary":"A race condition in Apache Guacamole's terminal emulator allows buffer overflows via overlapping writes, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"guacamole","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"A race condition in Guacamole's terminal emulator in versions 0.9.5 through 0.9.10-incubating could allow writes of blocks of printed data to overlap. Such overlapping writes could cause packet data to be misread as the packet length, resulting in the remaining data being written beyond the end of a statically-allocated buffer.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Guacamole Race Condition vulnerability","id":"CVE-2017-3158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"race_condition","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Camel's camel-snakeyaml component is vulnerable to Java object de-serialization","id":"CVE-2017-3159"},"packages":[{"ecosystem":"Maven","fixed":["0.9.11-incubating"],"introduced":["0.9.5"],"last_affected":[],"package":"org.apache.guacamole:guacamole-common","purl":null,"source":"GHSA-3vv3-585q-wv6x"},{"ecosystem":"Maven","fixed":["0.9.11-incubating"],"introduced":["0.9.5"],"last_affected":[],"package":"org.apache.guacamole:guacamole-common","purl":"pkg:maven/org.apache.guacamole/guacamole-common","source":"GHSA-3vv3-585q-wv6x"}],"prev":{"headline":"Information disclosure in Apache OpenOffice","id":"CVE-2017-3157"},"products":["Apache Guacamole"],"published":"2018-01-18","related":[{"cvss_score":8.8,"headline":"Improper validation of SAML responses","id":"CVE-2021-43999","kev_date_added":null,"published":"2022-01-11"},{"cvss_score":7.5,"headline":"Apache Guacamole: Integer overflow in handling of VNC image buffers","id":"CVE-2023-43826","kev_date_added":null,"published":"2023-12-19"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2019-19603","kev_date_added":null,"published":"2019-12-09"},{"cvss_score":7.5,"headline":"Missing Encryption of Sensitive Data in Apache Guacamole","id":"CVE-2018-1340","kev_date_added":null,"published":"2019-02-07"},{"cvss_score":6.8,"headline":"Apache Guacamole: Improper input validation of console codes","id":"CVE-2024-35164","kev_date_added":null,"published":"2025-07-02"},{"cvss_score":6.8,"headline":"Apache Guacamole: Use-after-free in handling of RDP audio input buffer","id":"CVE-2023-30576","kev_date_added":null,"published":"2023-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"A race condition in Apache Guacamole's terminal emulator allows buffer overflows via overlapping writes, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2017-3158/"}