# CVE-2017-3158: Apache Guacamole Race Condition vulnerability

> A race condition in Apache Guacamole's terminal emulator allows buffer overflows via overlapping writes, potentially leading to code execution or denial of service.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3vv3-585q-wv6x, UBUNTU-CVE-2017-3158

## What is CVE-2017-3158?

CVE-2017-3158 is a high-severity vulnerability in Apache Guacamole, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A race condition in Guacamole's terminal emulator in versions 0.9.5 through 0.9.10-incubating could allow writes of blocks of printed data to overlap. Such overlapping writes could cause packet data to be misread as the packet length, resulting in the remaining data being written beyond the end of a statically-allocated buffer.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2017-3158?

2 open source packages ship an affected version, including org.apache.guacamole:guacamole-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.guacamole:guacamole-common` | Maven | From 0.9.5 | 0.9.11-incubating |
| `org.apache.guacamole:guacamole-common` | Maven | From 0.9.5 | 0.9.11-incubating |

Products: Apache Guacamole.

## How do I fix CVE-2017-3158?

Upgrade org.apache.guacamole:guacamole-common to 0.9.11-incubating or later.

## Is CVE-2017-3158 being exploited?

There is no known exploitation of CVE-2017-3158 in the wild and no public exploit code.

## Other vulnerabilities in Apache Guacamole

- [CVE-2021-43999](https://insights.sbomify.com/CVE-2021-43999/): Improper validation of SAML responses (high 8.8)
- [CVE-2023-43826](https://insights.sbomify.com/CVE-2023-43826/): Apache Guacamole: Integer overflow in handling of VNC image buffers (high 7.5)
- [CVE-2019-19603](https://insights.sbomify.com/CVE-2019-19603/): Null dereference in n/a (high 7.5)
- [CVE-2018-1340](https://insights.sbomify.com/CVE-2018-1340/): Missing Encryption of Sensitive Data in Apache Guacamole (high 7.5)
- [CVE-2024-35164](https://insights.sbomify.com/CVE-2024-35164/): Apache Guacamole: Improper input validation of console codes (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-3158 and fix it if it is affected.

What it is: CVE-2017-3158 is a high-severity vulnerability in Apache Guacamole, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-3158 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.guacamole:guacamole-common (Maven): affected from 0.9.5; fixed in 0.9.11-incubating
- org.apache.guacamole:guacamole-common (Maven): affected from 0.9.5; fixed in 0.9.11-incubating

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-3158/ (Markdown: https://insights.sbomify.com/CVE-2017-3158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-3158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-3158
- OSV: https://osv.dev/vulnerability/CVE-2017-3158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-3158/
Summaries are generated and may contain mistakes; the official description above is the record.
