# CVE-2017-3163: Improper Limitation of a Pathname ('Path Traversal') in org.apache.solr:solr-core

> Attackers can read arbitrary files on the server via path traversal in the Index Replication feature if it is enabled and accessible.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2017
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-3163, DLA-1046-1, GHSA-387v-84cv-9qmc, UBUNTU-CVE-2017-3163

## What is CVE-2017-3163?

CVE-2017-3163 is a high-severity path traversal vulnerability in Apache Solr, published on 30 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When using the Index Replication feature, Apache Solr nodes can pull index files from a master/leader node using an HTTP API which accepts a file name. However, Solr before 5.5.4 and 6.x before 6.4.1 did not validate the file name, hence it was possible to craft a special request involving path traversal, leaving any file readable to the Solr server process exposed. Solr servers protected and restricted by firewall rules and/or authentication would not be at risk since only trusted clients and users would gain direct HTTP access.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-3163?

4 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | 5.5.4 |
| `org.apache.solr:solr-core` | Maven | All versions | 5.5.4 |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 6.4.1 |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 6.4.1 |

Products: Apache Solr.

## How do I fix CVE-2017-3163?

Upgrade org.apache.solr:solr-core to a fixed version for your release line: 5.5.4 or 6.4.1.

## Is CVE-2017-3163 being exploited?

There is no known exploitation of CVE-2017-3163 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-3163 and fix it if it is affected.

What it is: CVE-2017-3163 is a high-severity path traversal vulnerability in Apache Solr, published on 30 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-3163 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 5.5.4
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 5.5.4
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 6.4.1
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 6.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-3163/ (Markdown: https://insights.sbomify.com/CVE-2017-3163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-3163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-3163
- OSV: https://osv.dev/vulnerability/CVE-2017-3163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-3163/
Summaries are generated and may contain mistakes; the official description above is the record.
