# CVE-2017-3166: Moderate severity vulnerability that affects org.apache.hadoop:hadoop-main

> Attackers can read sensitive files from Hadoop encryption zones if they are world-readable and localized via YARN, exposing data to unauthorized applications.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-99qr-9cc9-fv2x

## What is CVE-2017-3166?

CVE-2017-3166 is a high-severity vulnerability in Apache Hadoop, published on 13 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Apache Hadoop versions 2.6.1 to 2.6.5, 2.7.0 to 2.7.3, and 3.0.0-alpha1, if a file in an encryption zone with access permissions that make it world readable is localized via YARN's localization mechanism, that file will be stored in a world-readable location and can be shared freely with any application that requests to localize that file.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2017-3166?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-main` | Maven | All versions | 2.7.3 |
| `org.apache.hadoop:hadoop-main` | Maven | All versions | 2.7.3 |

Products: Apache Hadoop.

## How do I fix CVE-2017-3166?

Upgrade org.apache.hadoop:hadoop-main to 2.7.3 or later.

## Is CVE-2017-3166 being exploited?

There is no known exploitation of CVE-2017-3166 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-3166 and fix it if it is affected.

What it is: CVE-2017-3166 is a high-severity vulnerability in Apache Hadoop, published on 13 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-3166 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-main (Maven): affected all versions; fixed in 2.7.3
- org.apache.hadoop:hadoop-main (Maven): affected all versions; fixed in 2.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-3166/ (Markdown: https://insights.sbomify.com/CVE-2017-3166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-3166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-3166
- OSV: https://osv.dev/vulnerability/CVE-2017-3166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-3166/
Summaries are generated and may contain mistakes; the official description above is the record.
