# CVE-2017-3586: Exposure of Sensitive Information to an Unauthorized Actor in Oracle MySQL Connectors Java

> Low-privileged attackers can bypass authorization to read, update, insert, or delete data via MySQL Connector/J.

- **Severity:** Medium 6.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2017
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-pwh7-92h3-mqr6, UBUNTU-CVE-2017-3586

## What is CVE-2017-3586?

CVE-2017-3586 is a medium-severity missing authorization vulnerability in Oracle Corporation MySQL Connectors, published on 24 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/J). Supported versions that are affected are 5.1.41 and earlier. Easily "exploitable" vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. While the vulnerability is in MySQL Connectors, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Connectors accessible data as well as unauthorized read access to a subset of MySQL Connectors accessible data. CVSS 3.0 Base Score 6.4 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N).

## Which versions are affected by CVE-2017-3586?

2 open source packages ship an affected version, including mysql:mysql-connector-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql:mysql-connector-java` | Maven | All versions | 5.1.42 |
| `mysql:mysql-connector-java` | Maven | All versions | 5.1.42 |

Products: Oracle Mysql Connectors.

## How do I fix CVE-2017-3586?

Upgrade mysql:mysql-connector-java to 5.1.42 or later.

## Is CVE-2017-3586 being exploited?

There is no known exploitation of CVE-2017-3586 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Corporation MySQL Connectors

- [CVE-2022-21363](https://insights.sbomify.com/CVE-2022-21363/): Improper Handling of Insufficient Permissions or Privileges in MySQL Connectors Java (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-3586 and fix it if it is affected.

What it is: CVE-2017-3586 is a medium-severity missing authorization vulnerability in Oracle Corporation MySQL Connectors, published on 24 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-3586 in the wild and no public exploit code.

Affected packages and fixed versions:
- mysql:mysql-connector-java (Maven): affected all versions; fixed in 5.1.42
- mysql:mysql-connector-java (Maven): affected all versions; fixed in 5.1.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-3586/ (Markdown: https://insights.sbomify.com/CVE-2017-3586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-3586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-3586
- OSV: https://osv.dev/vulnerability/CVE-2017-3586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-3586/
Summaries are generated and may contain mistakes; the official description above is the record.
