{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-3735 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-3735 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-3735 and fix it if it is affected.\n\nWhat it is: CVE-2017-3735 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-3735 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-3735/ (Markdown: https://insights.sbomify.com/CVE-2017-3735/index.md)","id":"CVE-2017-3735","markdown":"https://insights.sbomify.com/CVE-2017-3735/index.md","name":"CVE-2017-3735","record":{"aliases":["ALPINE-CVE-2017-3735","DEBIAN-CVE-2017-3735","DLA-1157-1","DSA-4018-1","GHSA-6h3q-hmhp-4vgv","SUSE-SU-2017:2968-1","SUSE-SU-2017:2981-1","UBUNTU-CVE-2017-3735"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenSSL library","requires_auth":"none","summary":"A one-byte overread in OpenSSL's X.509 certificate parsing allows attackers to read adjacent memory, potentially disclosing sensitive information.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openssl","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"openssl","vendor":"openssl"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"While parsing an IPAddressFamily extension in an X.509 certificate, it is possible to do a one-byte overread. This would result in an incorrect text display of the certificate. This bug has been present since 2006 and is present in all versions of OpenSSL before 1.0.2m and 1.1.0g.","ecosystems":["SUSE:Linux Enterprise Server 11-SECURITY","SUSE:Linux Enterprise Server 12 SP1-LTSS","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:OpenStack Cloud 6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in OpenSSL","id":"CVE-2017-3735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","openssl:openssl"],"type":"information_disclosure","year":"2017"},"n_packages":4,"n_references":27,"next":{"headline":"Information disclosure in OpenSSL","id":"CVE-2017-3736"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 11-SECURITY","fixed":["1.0.1g-0.58.3.1"],"introduced":["0"],"last_affected":[],"package":"openssl1","purl":"pkg:rpm/suse/openssl1\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011-SECURITY","source":"SUSE-SU-2017:2968-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1-LTSS","fixed":["1.0.1i-54.8.1"],"introduced":["0"],"last_affected":[],"package":"openssl","purl":"pkg:rpm/suse/openssl\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1-LTSS","source":"SUSE-SU-2017:2981-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["1.0.1i-54.8.1"],"introduced":["0"],"last_affected":[],"package":"openssl","purl":"pkg:rpm/suse/openssl\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2017:2981-1"},{"ecosystem":"SUSE:OpenStack Cloud 6","fixed":["1.0.1i-54.8.1"],"introduced":["0"],"last_affected":[],"package":"openssl","purl":"pkg:rpm/suse/openssl\u0026distro=SUSE%20OpenStack%20Cloud%206","source":"SUSE-SU-2017:2981-1"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-3734"},"products":["OpenSSL"],"published":"2017-08-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["OpenSSL Software Foundation"]},"summary":"A one-byte overread in OpenSSL's X.509 certificate parsing allows attackers to read adjacent memory, potentially disclosing sensitive information.","url":"https://insights.sbomify.com/CVE-2017-3735/"}