CVE-2017-4960 Cloud Foundry denial of service vulnerability

High 7.5 Published Updated

Attackers can cause a denial of service against Cloud Foundry UAA OAuth clients, affecting cloud platform availability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-4960?

CVE-2017-4960 is a high-severity denial of service vulnerability in Cloud Foundry Foundation Cloud Foundry release v247 - v252, UAA stand-alone release v3.9.0 - v3.11.0, UAA Bosh Release v21 - v26, published on 10 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Cloud Foundry release v247 through v252, UAA stand-alone release v3.9.0 through v3.11.0, and UAA Bosh Release v21 through v26. There is a potential to subject the UAA OAuth clients to a denial of service attack.

Which versions are affected by CVE-2017-4960?

4 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.

PackageAffectedFixed in
org.cloudfoundry.identity:cloudfoundry-identity-server MavenAll versions3.9.8
org.cloudfoundry.identity:cloudfoundry-identity-server MavenAll versions3.9.8
org.cloudfoundry.identity:cloudfoundry-identity-server MavenFrom 3.10.03.12.0
org.cloudfoundry.identity:cloudfoundry-identity-server MavenFrom 3.10.03.12.0

Products include Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry, Pivotal Software Cloud Foundry Uaa.

How do I fix CVE-2017-4960?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.9.8 or 3.12.0.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2017-4960 being exploited?

There is no known exploitation of CVE-2017-4960 in the wild and no public exploit code.

Sources

Also known as GHSA-hxgw-7539-pv7r.

Is CVE-2017-4960 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free