{"answers":{"affected":"4 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.","exploited":"There is no known exploitation of CVE-2017-4960 in the wild and no public exploit code.","fix":"Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.9.8 or 3.12.0.","what":"CVE-2017-4960 is a high-severity denial of service vulnerability in Cloud Foundry Foundation Cloud Foundry release v247 - v252, UAA stand-alone release v3.9.0 - v3.11.0, UAA Bosh Release v21 - v26, published on 10 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-4960 and fix it if it is affected.\n\nWhat it is: CVE-2017-4960 is a high-severity denial of service vulnerability in Cloud Foundry Foundation Cloud Foundry release v247 - v252, UAA stand-alone release v3.9.0 - v3.11.0, UAA Bosh Release v21 - v26, published on 10 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-4960 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.9.8\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.9.8\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.12.0\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-4960/ (Markdown: https://insights.sbomify.com/CVE-2017-4960/index.md)","id":"CVE-2017-4960","markdown":"https://insights.sbomify.com/CVE-2017-4960/index.md","name":"CVE-2017-4960","record":{"aliases":["GHSA-hxgw-7539-pv7r"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloud Foundry UAA","requires_auth":"none","summary":"Attackers can cause a denial of service against Cloud Foundry UAA OAuth clients, affecting cloud platform availability.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dell","cpe":[{"product":"cloud_foundry_uaa_bosh","vendor":"cloudfoundry"},{"product":"cloud_foundry","vendor":"pivotal_software"},{"product":"cloud_foundry_uaa","vendor":"pivotal_software"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[],"description":"An issue was discovered in Cloud Foundry release v247 through v252, UAA stand-alone release v3.9.0 through v3.11.0, and UAA Bosh Release v21 through v26. There is a potential to subject the UAA OAuth clients to a denial of service attack.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cloud Foundry denial of service vulnerability","id":"CVE-2017-4960","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":4,"n_references":2,"next":{"headline":"Command injection in Cloud Foundry Foundation BOSH Release","id":"CVE-2017-4961"},"packages":[{"ecosystem":"Maven","fixed":["3.9.8"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-hxgw-7539-pv7r"},{"ecosystem":"Maven","fixed":["3.9.8"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-hxgw-7539-pv7r"},{"ecosystem":"Maven","fixed":["3.12.0"],"introduced":["3.10.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-hxgw-7539-pv7r"},{"ecosystem":"Maven","fixed":["3.12.0"],"introduced":["3.10.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-hxgw-7539-pv7r"}],"prev":{"headline":"Auth bypass in PCF Elastic Runtime","id":"CVE-2017-4959"},"products":["Cloud Foundry Foundation Cloud Foundry release v247 - v252, UAA stand-alone release v3.9.0 - v3.11.0, UAA Bosh Release v21 - v26"],"published":"2017-03-10","related":[{"cvss_score":9.6,"headline":"Cloud Foundry vulnerable to Cross-Site Request Forgery","id":"CVE-2016-6637","kev_date_added":null,"published":"2016-09-30"},{"cvss_score":8.8,"headline":"Cloud Foundry UAA Privilege Escalation","id":"CVE-2017-4973","kev_date_added":null,"published":"2017-06-13"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2016-4468","kev_date_added":null,"published":"2017-04-11"},{"cvss_score":8.8,"headline":"Privilege escalation in n/a","id":"CVE-2016-6651","kev_date_added":null,"published":"2016-09-30"},{"cvss_score":8.1,"headline":"Cloud Foundry UAA reset password vulnerable to brute force attack","id":"CVE-2016-3084","kev_date_added":null,"published":"2017-05-25"},{"cvss_score":8.1,"headline":"Privilege escalation in Cloud Foundry v247 and earlier and UAA v3.9.2 \u0026 earlier and UAA bosh (uaa-release) v23 \u0026 earlier","id":"CVE-2016-6659","kev_date_added":null,"published":"2016-12-23"},{"cvss_score":7.5,"headline":"Other in Cloud Foundry","id":"CVE-2017-4994","kev_date_added":null,"published":"2017-06-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause a denial of service against Cloud Foundry UAA OAuth clients, affecting cloud platform availability.","url":"https://insights.sbomify.com/CVE-2017-4960/"}