# CVE-2017-4960: Cloud Foundry denial of service vulnerability

> Attackers can cause a denial of service against Cloud Foundry UAA OAuth clients, affecting cloud platform availability.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hxgw-7539-pv7r

## What is CVE-2017-4960?

CVE-2017-4960 is a high-severity denial of service vulnerability in Cloud Foundry Foundation Cloud Foundry release v247 - v252, UAA stand-alone release v3.9.0 - v3.11.0, UAA Bosh Release v21 - v26, published on 10 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Cloud Foundry release v247 through v252, UAA stand-alone release v3.9.0 through v3.11.0, and UAA Bosh Release v21 through v26. There is a potential to subject the UAA OAuth clients to a denial of service attack.

## Which versions are affected by CVE-2017-4960?

4 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.9.8 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.9.8 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.12.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.12.0 |

Products: Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2017-4960?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.9.8 or 3.12.0.

## Is CVE-2017-4960 being exploited?

There is no known exploitation of CVE-2017-4960 in the wild and no public exploit code.

## Other vulnerabilities in Cloud Foundry Foundation Cloud Foundry release v247 - v252, UAA stand-alone release v3.9.0 - v3.11.0, UAA Bosh Release v21 - v26

- [CVE-2016-6637](https://insights.sbomify.com/CVE-2016-6637/): Cloud Foundry vulnerable to Cross-Site Request Forgery (critical 9.6)
- [CVE-2017-4973](https://insights.sbomify.com/CVE-2017-4973/): Cloud Foundry UAA Privilege Escalation (high 8.8)
- [CVE-2016-4468](https://insights.sbomify.com/CVE-2016-4468/): SQL injection in n/a (high 8.8)
- [CVE-2016-6651](https://insights.sbomify.com/CVE-2016-6651/): Privilege escalation in n/a (high 8.8)
- [CVE-2016-3084](https://insights.sbomify.com/CVE-2016-3084/): Cloud Foundry UAA reset password vulnerable to brute force attack (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-4960 and fix it if it is affected.

What it is: CVE-2017-4960 is a high-severity denial of service vulnerability in Cloud Foundry Foundation Cloud Foundry release v247 - v252, UAA stand-alone release v3.9.0 - v3.11.0, UAA Bosh Release v21 - v26, published on 10 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-4960 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.9.8
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.9.8
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.12.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-4960/ (Markdown: https://insights.sbomify.com/CVE-2017-4960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-4960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-4960
- OSV: https://osv.dev/vulnerability/CVE-2017-4960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-4960/
Summaries are generated and may contain mistakes; the official description above is the record.
